Follow

What are the miminum system requirements for TotilPay Go?

TotilPay Go is compatible with iOS (Apple mobile) devices running iOS 11.0 or higher and some Android mobile devices running Android 4.0 or higher.*

iOS (Apple Mobile)

TotilPay Go for iOS is compatible with iPads and iPhones running iOS 11.0 or higher. Click here to view a list of compatible devices at Apple's support site.

Android

TotilPay Go for Android is compatible with many Android mobile devices running Android 4.0 or higher. Click here to view the Android Ice Cream Sandwich Wikipedia page.

* A stable wireless internet connection is also required to process electronic transactions.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk